Jump to content
Ménemszól.hu
  • 0

Digitális zongora MIDI vezérlésre


rasguardo
 Share

Kérdés

Sziasztok!

Adott egy 2019 late iMac 27" i9 gép a legfrissebb Big Sur (tudom, tudom...kár volt) rendszerrel.

Audio interface: Antelope Audio Zen Go

DAW: Cubase, Nuendo, ProTools, Reaper, Ableton

VSTi: Waves szintik, EastWest, Spitfire, Native Instruments...etc...sokminden

A problémám a következő:

Egy 2009es Yamaha YDP 140 zongorát szeretnék használni masterkeyboardként. Kétféle képpen próbáltam a gépemre kötni:

1. Midisport UNO: lenyomom a billentyűt, beragad. Csak akkor hagyja abba, hogyha a zongora programváltóját benyomom.

2. M-Audio CODE 25 bilentyűmön keresztül (ami class compliant): lenyomom a billentyűt, beragad. Az M-Audion kell ugyanazt a hangot lenyomnom, hogy releaselje.

Midimonitor a következőket mutatja: noteON megérkezik a zongorámból, de noteOFF csak az M-Audioból tud érkezni. Erre azt olvastam, hogy a zongora noteON-ra egy zero velocityt küld OFF helyett. Nade, ezt valamiért nem akarja felismerni a macem.

Mit tudnék tenni ilyenkor? Oprendszer visszaváltás nem opció és Windowst sem szeretnék bootcampben használni.

Előre is köszi!

Szerkesztette rasguardo
Link to comment
Share on other sites

válasz erre a kérdésre

Recommended Posts

  • 0

Szia,
Nem gondolom, hogy a Mac nem ismerné fel a velocity 0-t.
Hasonló rendszeren vagyok mint te (Yamaha CP33, M-Audio Midisport 4x4, Mac Mini 2014 Mojave), és az én digit zongorám is Velocity 0-t küld ki Note Off helyett.

Azt javasolnám, hogy installáld fel az M-Audio Midisport driverét, az utolsó verziót, mert úgy látom a Big Surre még nem adtak ki külön drivert. (Az a tapasztalatom, hogy a MIDI interfészeknek kell a driver, mert másképp nem működnek jól.)

Sok szerencsét.
 

Link to comment
Share on other sites

  • 0
6 perccel ezelőtt írta KR~:

Szia,
Nem gondolom, hogy a Mac nem ismerné fel a velocity 0-t.
Hasonló rendszeren vagyok mint te (Yamaha CP33, M-Audio Midisport 4x4, Mac Mini 2014 Mojave), és az én digit zongorám is Velocity 0-t küld ki Note Off helyett.

Azt javasolnám, hogy installáld fel az M-Audio Midisport driverét, az utolsó verziót, mert úgy látom a Big Surre még nem adtak ki külön drivert. (Az a tapasztalatom, hogy a MIDI interfészeknek kell a driver, mert másképp nem működnek jól.)

Sok szerencsét.
 

Nem supportálja a drivert a big sur, sajnos. Azt már próbáltam. De az M-Audio billentyűn keresztül kötve is ugyanúgy rossz. Lehet, hogy valami nagyon friss kiadású midi interface megoldaná ezt a problémát? A midisport uno az nem igazán mai darab már.

Link to comment
Share on other sites

  • 0

Nagyon furcsa, hogy nem kapja meg a Mac a Velocity 0-t.
Másik számítógépen is van ez a probléma? 
Próbáld ki más gépen v. oprendszeren, ha még nem próbáltad. Kiszűröd, hogy az oprendszer a ludas vagy esetleg a zongorával v. interfésszel van a probléma, vagy valami beállítási hiba.

Link to comment
Share on other sites

  • 0
Ekkor: 2021. 10. 01. at 14:24 írta rasguardo:

Egy 2009es Yamaha YDP 140 zongorát

Pár éve én is ugyanezt a típust akartam MIDI billentyűnek használni. Nekem meg a Sustain pedált nem küldte ki. A hangszer végrehajtotta, de a MIDI track-et visszajátszva nem voltak SUSTAIN utasítások. Valami nem kerek azzal a hangszerrel MIDI téren. Nekem felhúzta az agyamat, fel is adtam hogy foglalkozzak vele.

Az esetedben én is kipróbálnám más helyzetben, iPad-el, iPhone-al vagy PC-vel.

Link to comment
Share on other sites

  • 0
Ekkor: 2021. 10. 02. at 20:42 írta Koródi Csaba:

Pár éve én is ugyanezt a típust akartam MIDI billentyűnek használni. Nekem meg a Sustain pedált nem küldte ki. A hangszer végrehajtotta, de a MIDI track-et visszajátszva nem voltak SUSTAIN utasítások. Valami nem kerek azzal a hangszerrel MIDI téren. Nekem felhúzta az agyamat, fel is adtam hogy foglalkozzak vele.

Az esetedben én is kipróbálnám más helyzetben, iPad-el, iPhone-al vagy PC-vel.

Sustain még nem is lenne probléma, mert azt küldöm a CODE-25 bemenetén. De igen...egyelőre úgy néz ki, hogy meg kell próbálnom valamit, ami NEM Big Sur, sajnos. 

Link to comment
Share on other sites

  • 0
Ekkor: 2021. 10. 02. at 20:06 írta KR~:

Nagyon furcsa, hogy nem kapja meg a Mac a Velocity 0-t.
Másik számítógépen is van ez a probléma? 
Próbáld ki más gépen v. oprendszeren, ha még nem próbáltad. Kiszűröd, hogy az oprendszer a ludas vagy esetleg a zongorával v. interfésszel van a probléma, vagy valami beállítási hiba.

Kipróbáltam Win gépen. Drivert feltettem a midisporthoz. De ugyanaz, mint macen. A midisport 'midi in' lámpácskája folyamatosan flashel. És ugyanúgy beragad. A zongorán pedig cserélve lett a Yamahától rendelt gyári alkatrészekkel a full midi részleg. Még az aljzatok is.

Link to comment
Share on other sites

  • 0
Ekkor: 2021. 10. 02. at 18:53 írta KR~:

úgy látom a Big Surre még nem adtak ki külön drivert

Van egy UNO-m nekem is és korábban azt olvastam, hogy ezt nem is fogják később támogatni BS-on. Az Apple nagyon köcsög tud lenni régi hardverekkel ha akar! :( 

Link to comment
Share on other sites

  • 0
2 órája írta rasguardo:

Kipróbáltam Win gépen.

Monitorozd ki egy MIdiOX-el. Ha baj van, akkor tényleg kuka a Yamaha, bár pont azoknál ilyenre még nem hallottam problémát. Esetleg kérdezd meg Miskolczi Pétert (Hangjegy Bt.) hivatalos hazai yamaha szerviz.

Link to comment
Share on other sites

  • 0
2 perccel ezelőtt írta djuice:

Monitorozd ki egy MIdiOX-el. Ha baj van, akkor tényleg kuka a Yamaha, bár pont azoknál ilyenre még nem hallottam problémát. Esetleg kérdezd meg Miskolczi Pétert (Hangjegy Bt.) hivatalos hazai yamaha szerviz.

Peti szerelte meg a Yamahámat. De itt sajnos kompatibilitási problémák lesznek. Megnéztem winen is, hogy milyen üzeneteket küld a cucc, és halálpontosan ugyanazt csinálja, mint macen. Teljesen mindegy, hogy midisporttal küldöm, vagy a CODE-on keresztül. És ezt már azután, hogy Peti konkrétan mindent kicserélt benne, ami midi. Úgyhogy kezdem elengedni ezt a zongorát. Nem hibáztatom a zongit, mert 2009es darab. Csak örültem volna, ha megszólal.

Link to comment
Share on other sites

  • 0
10 órája írta Kiskádár:

Az YDP-140-nél le lehet tiltani a Control Change üzenetek küldését+fogadását, szóval ezt még meg lehet magyarázni.

Értem. Tulajdonképpen igen, ezzel magyarázható elviekben... de annál sokkal összevisszább csinálta nálam, és nem tiltottam le.

Link to comment
Share on other sites

  • 0

Ez a két dolog így egymás után leírva elég furcsán néz ki:
1."Megnéztem winen is, hogy milyen üzeneteket küld a cucc, és halálpontosan ugyanazt csinálja, mint macen. Teljesen mindegy, hogy midisporttal küldöm, vagy a CODE-on keresztül. És ezt már azután, hogy Peti konkrétan mindent kicserélt benne, ami midi." 
2."Elvileg lepróbálták a Hangszerplázában, ahol összerakta. De ott valami régebbi macOS verziókkal lett nézve. Elvileg."

Nem lehet, hogy valahogy a Midisport/M-Audio és a Yamaha YDP-140 kombója okozza a problémát? Ha a Yamaha MIDI Out-ját egy vas hangmodul vagy vas szintetizátor MIDI In-ével kötöd össze, akkor is beragad a hang?
Van olyan vas eszközöm, ami a száraz MIDI forgalmat mutatja, ha bp-i lennék, azzal nézném meg ezt a Yamahát. Meg persze a saját számítógépeimmel és MIDI interfészeimmel.

Szerkesztette Kiskádár
Link to comment
Share on other sites

  • 0
30 perccel ezelőtt írta Kiskádár:

Ez a két dolog így egymás után leírva elég furcsán néz ki:
1."Megnéztem winen is, hogy milyen üzeneteket küld a cucc, és halálpontosan ugyanazt csinálja, mint macen. Teljesen mindegy, hogy midisporttal küldöm, vagy a CODE-on keresztül. És ezt már azután, hogy Peti konkrétan mindent kicserélt benne, ami midi." 
2."Elvileg lepróbálták a Hangszerplázában, ahol összerakta. De ott valami régebbi macOS verziókkal lett nézve. Elvileg."

Nem lehet, hogy valahogy a Midisport/M-Audio és a Yamaha YDP-140 kombója okozza a problémát? Ha a Yamaha MIDI Out-ját egy vas hangmodul vagy vas szintetizátor MIDI In-ével kötöd össze, akkor is beragad a hang?
Van olyan vas eszközöm, ami a száraz MIDI forgalmat mutatja, ha bp-i lennék, azzal nézném meg ezt a Yamahát. Meg persze a saját számítógépeimmel és MIDI interfészeimmel.

Bármin keresztül kötöm, ugyanazt csinálja. Nemcsak a midisporttal. a Hangszerplázában meg mint utólag kiderült, windows gépen nézték. És amikor kérdeztem, hogy pontosan milyen eszközökkel, milyen gépen, milyen csatlakozással, melyik oprendszerrel...akkor meg ez volt: "Hát a kolléga már nem dolgozik itt."

Link to comment
Share on other sites

  • 0

MEGLETT A MEGOLDÁS

Szószerint minden midikábelt és interfészt kipróbáltam már 500ft-tól 90ezer forintig. És semmi nem volt jó. Ma egy haverom a kezembenyomott egy Roland UM ONE mk2 kis interfészt. Bedugtam és azonnal tökéletesen működik minden. Még a pedálok is. Minden beállítás nélkül.

Megmenekült a zongorám és az idegrendszerem :D

Link to comment
Share on other sites

  • 0
10 órája írta rasguardo:

Bedugtam és azonnal tökéletesen működik minden. Még a pedálok is. Minden beállítás nélkül.

Megmenekült a zongorám

Ez viszont már sokkal érdekesebb, hogy mit tud szexelni egymással egy Yamaha és egy Roland, ami a Macival nem megy! :wacko::stuff:

Link to comment
Share on other sites

  • 0
3 órája írta djuice:

Ez viszont már sokkal érdekesebb, hogy mit tud szexelni egymással egy Yamaha és egy Roland, ami a Macival nem megy! :wacko::stuff:

Ez egy borzalmasan jó kérdés. És elég érdekes, hogy literally semmi mással nem működik, csak ezzel. És ezzel viszont minden feature perfect. De ezt a részét én már meghagyom a profiknak :D Én csak szimplán borzalmasan boldog vagyok, hogy nem kell kidobnom a zongorát az emeleti csukott ablakon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Válaszolok a kérdésre...

×   Formázott tartalmat illesztettél be.   Kattints a formázás megszűntetéséhez.

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...